$re = '/^(\d*\.\d*?[1-9])0+$/m';
$str = '0.100103200000
1.987312730
789123489217
0.100000000000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);