import re
regex = re.compile(r"^(\d*\.\d*?[1-9])0+$", flags=re.MULTILINE)
test_str = ("0.100103200000\n"
"1.987312730\n"
"789123489217\n"
"0.100000000000000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")