#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$(\d{1,3}[\.,]*)+"
Local $sString = "$5.34" & @CRLF & _
"$5,34" & @CRLF & _
"$222,100,455.34" & @CRLF & _
"$222.100.455,34" & @CRLF & _
"" & @CRLF & _
"$222,100,455" & @CRLF & _
"$222.100.455" & @CRLF & _
"" & @CRLF & _
"$4,13 + $5,24 = $9,37" & @CRLF & _
"$4,13 + $1.005,24 = $1.009,37" & @CRLF & _
"$8.000 - $8.000 = $0" & @CRLF & _
"" & @CRLF & _
"$4.545,45 is less than $5,454.54." & @CRLF & _
"$4,545.45 is less than $5.454,54." & @CRLF & _
"Our movie tickets cost $12,20." & @CRLF & _
"" & @CRLF & _
"127.255.255.255" & @CRLF & _
"" & @CRLF & _
"Clayton Kershaw $31.000.000" & @CRLF & _
"Zack Greinke $27.000.000" & @CRLF & _
"Adrian Gonzalez $21.857.143" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")