import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$(\\d{1,3}[\\.,]*)+";
final String string = "$5.34\n"
+ "$5,34\n"
+ "$222,100,455.34\n"
+ "$222.100.455,34\n\n"
+ "$222,100,455\n"
+ "$222.100.455\n\n"
+ "$4,13 + $5,24 = $9,37\n"
+ "$4,13 + $1.005,24 = $1.009,37\n"
+ "$8.000 - $8.000 = $0\n\n"
+ "$4.545,45 is less than $5,454.54.\n"
+ "$4,545.45 is less than $5.454,54.\n"
+ "Our movie tickets cost $12,20.\n\n"
+ "127.255.255.255\n\n"
+ "Clayton Kershaw $31.000.000\n"
+ "Zack Greinke $27.000.000\n"
+ "Adrian Gonzalez $21.857.143\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}