package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+)(\$)([\d+,]+)$`)
var str = `Your Annual Income:* $1,316,422`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}