$re = '/^(.+)(\$)([\d+,]+)$/m';
$str = 'Your Annual Income:* $1,316,422';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);