$re = '/(?<!\S)-?\d*\.?\d+(?:\|-?\d*\.?\d+){3}(?!\S)/m';
$str = 'SOME STRING CONTENT 13|5|-1|3 MORE 1.6 CONTENT HERE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);