re = /(?<!\S)-?\d*\.?\d+(?:\|-?\d*\.?\d+){3}(?!\S)/m
str = 'SOME STRING CONTENT 13|5|-1|3 MORE 1.6 CONTENT HERE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end