#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\w\.]+@[a-zA-Z_]+?(\.[a-zA-Z]{2,6})+"
Local $sString = "// Valid" & @CRLF & _
"mail@mail.ru" & @CRLF & _
"mail.mail@mail.ru" & @CRLF & _
"mail@mail.mail.ru" & @CRLF & _
"" & @CRLF & _
"// Invalid" & @CRLF & _
"@.ru" & @CRLF & _
"@mail.ru" & @CRLF & _
"mail.ru" & @CRLF & _
"mail@mail" & @CRLF & _
"mail@mail.mail."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")