package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w\.]+@[a-zA-Z_]+?(\.[a-zA-Z]{2,6})+`)
var str = `// Valid
mail@mail.ru
mail.mail@mail.ru
mail@mail.mail.ru
// Invalid
@.ru
@mail.ru
mail.ru
mail@mail
mail@mail.mail.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}