re = /(\u00a9|\u00ae|[\u2000-\u3300]|\ud83c[\ud000-\udfff]|\ud83d[\ud000-\udfff]|\ud83e[\ud000-\udfff])/m
str = 'hello
hello ✅
tomorrow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end