package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[$*[*]`)
var str = `$Zone/F090,30:ae:a4:96:f0:92,-19,0201060512200040000201060e0949475f463039302056322e3530020a03051220004000,36*,1672311124`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}