const regex = /[$*[*]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[$*[*]', 'gm')
const str = `\$Zone/F090,30:ae:a4:96:f0:92,-19,0201060512200040000201060e0949475f463039302056322e3530020a03051220004000,36*,1672311124`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}