package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d*(\.\d\d)?(\$|руб)`)
var str = `100$
103.45$
100руб
103.45руб`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}