$re = '/\d*(\.\d\d)?(\$|руб)/m';
$str = '100$
103.45$
100руб
103.45руб';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);