re = /ABC(?!.*MNO)(?=.*XYZ)/m
str = 'Lorem `ABC` ipsum ABC bla MNO bla ipsum ABC asfg 123 hello ABC dd ABC XYZ hello ABC
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result