$re = '/^([^-]+-[^-]+)-([^-]+-[^-]+)-(.*)$/m';
$str = 'foo-bar-fort-worth-tx
1st group: (foo-bar) 2nd group: (fort-worth) 3rd group: (tx)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);