re = /^([^-]+-[^-]+)-([^-]+-[^-]+)-(.*)$/m
str = 'foo-bar-fort-worth-tx
1st group: (foo-bar) 2nd group: (fort-worth) 3rd group: (tx)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end