import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([^a,e,i,o,u]{0,}qu|[^a,e,i,o,u]+)([a,e,i,o,u][a-z]+)?";
final String string = "quiet\n"
+ "school\n"
+ "three\n"
+ "banana\n"
+ "apple\n"
+ "square";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}