package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-zA-Z]{3,9}:(\/){2})?([a-zA-Z0-9\.]*){1}(?::[a-zA-Z0-9]{1,4})?(?:\/[_\,\'\$#~\?\-\+=&;%@\.\w%]+)*(?:\/)?$`)
var str = `test.com/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}