const regex = /^([a-zA-Z]{3,9}:(\/){2})?([a-zA-Z0-9\.]*){1}(?::[a-zA-Z0-9]{1,4})?(?:\/[_\,\'\$#~\?\-\+=&;%@\.\w%]+)*(?:\/)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]{3,9}:(\\\/){2})?([a-zA-Z0-9\\.]*){1}(?::[a-zA-Z0-9]{1,4})?(?:\\\/[_\\,\\\'\\$#~\\?\\-\\+=&;%@\\.\\w%]+)*(?:\\\/)?$', '')
const str = `test.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}