using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bEOL\s+\w+|(?<!\d)([09]?\d{5})(?!\d)";
string input = @"EOL I11011
942194
42143
weoijf23412dfd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}