$re = '/\bEOL\s+\w+|(?<!\d)([09]?\d{5})(?!\d)/m';
$str = 'EOL I11011
942194
42143
weoijf23412dfd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);