package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0[56][0-9]{7}$`)
var str = `068852123
0522321485`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}