$re = '/^0[56][0-9]{7}$/m';
$str = '068852123
0522321485';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);