const regex = new RegExp('(?P<ssid>.*?)\\s+(?P<mac>(?:[a-zA-Z\\d]{2}:){5}[a-zA-Z\\d]{2})\\s+(?P<signal>[-\\d]+)', '')
const str = `Vivo 4G Plus 08:63:61:8d:95:dc -85 11 Y -- WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}