re = /(?P<ssid>.*?)\s+(?P<mac>(?:[a-zA-Z\d]{2}:){5}[a-zA-Z\d]{2})\s+(?P<signal>[-\d]+)/
str = 'Vivo 4G Plus 08:63:61:8d:95:dc -85 11 Y -- WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end