$re = '/^(?=.*(?<User>(?<=user:)[^]]*))(?=.*(?<Serial_Number>(?<=sn:)[^]]*))/m';
$str = '<Jul24,11:20:17> TID:6 INFO [user:weblogic] [sn:088039] [dur:806ms] {***message***}>
<Jul24,11:20:17> TID:6 INFO [sn:088039] [dur:806ms] {***message***}> [user:weblogic] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);