import re
regex = re.compile(r"^(?=.*(?<User>(?<=user:)[^]]*))(?=.*(?<Serial_Number>(?<=sn:)[^]]*))", flags=re.MULTILINE)
test_str = ("<Jul24,11:20:17> TID:6 INFO [user:weblogic] [sn:088039] [dur:806ms] {***message***}>\n"
"<Jul24,11:20:17> TID:6 INFO [sn:088039] [dur:806ms] {***message***}> [user:weblogic] ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")