package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d+\b`)
var str = `a b cddde ff 1
5
hH five lll 0
l 10
99 abcd7
9kk
0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}