import re
regex = re.compile(r"\b\d+\b")
test_str = ("a b cddde ff 1\n"
"5\n"
"hH five lll 0\n"
"l 10\n"
"99 abcd7\n"
"9kk\n"
"0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")