#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)\h+(\S+)\h+(\w+)\h+\w+\h+\d*\h+\#\h+\S+\h+\d+\h+\d+\b(?!\h+EMPTY)\s*(.*)"
Local $sString = "CATALYST_TH 1" & @CRLF & _
"BACKPLANE A" & @CRLF & _
"#Slot Type Serial # Rev Num Date XptA XptB Name" & @CRLF & _
" 2 879-858-35 0x0109037 A 0 # 0131-0 23 24 PLFD CC" & @CRLF & _
" 6 879-857-01 0x0253bb0 A 0 # 9517-0 15 16 PMM CC-01" & @CRLF & _
" 7 000-000-00 0x0000000 P0 0 # 0000-0 13 14 EMPTY " & @CRLF & _
" 8 000-000-00 0x0000000 P0 0 # 0000-0 11 12 EMPTY " & @CRLF & _
" 9 000-000-00 0x0000000 P0 0 # 0000-0 9 10 EMPTY " & @CRLF & _
" 10 000-000-00 0x0000000 P0 0 # 0000-0 7 8 EMPTY " & @CRLF & _
" 20 000-000-00 0x0000000 P0 0 # 0000-0 37 38 EMPTY " & @CRLF & _
" 21 000-000-00 0x0000000 P0 0 # 0000-0 39 40 EMPTY " & @CRLF & _
" 22 000-000-00 0x0000000 P0 0 # 0000-0 41 42 EMPTY " & @CRLF & _
" 23 000-000-00 0x01a2446 P0 0 # 0000-0 43 44 EMPTY " & @CRLF & _
" 1 949-669-00 0x026a850 B 0 # 0809-0 3 0 HAS (Left HAS LA669-00)" & @CRLF & _
" 13 949-668-00 0x200762d A 0 # 9530-0 0 0 CATALYST HAC" & @CRLF & _
" 12 949-667-00 0x026a4ee D 0 # 0102-0 0 0 DIF" & @CRLF & _
" 24 949-669-01 0x2006037 B 0 # 9717-0 4 0 HAS (Right HAS LA669-01)" & @CRLF & _
"END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")