import Foundation
let pattern = ##"(\d+)\h+(\S+)\h+(\w+)\h+\w+\h+\d*\h+\#\h+\S+\h+\d+\h+\d+\b(?!\h+EMPTY)\s*(.*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
CATALYST_TH 1
BACKPLANE A
#Slot Type Serial # Rev Num Date XptA XptB Name
2 879-858-35 0x0109037 A 0 # 0131-0 23 24 PLFD CC
6 879-857-01 0x0253bb0 A 0 # 9517-0 15 16 PMM CC-01
7 000-000-00 0x0000000 P0 0 # 0000-0 13 14 EMPTY
8 000-000-00 0x0000000 P0 0 # 0000-0 11 12 EMPTY
9 000-000-00 0x0000000 P0 0 # 0000-0 9 10 EMPTY
10 000-000-00 0x0000000 P0 0 # 0000-0 7 8 EMPTY
20 000-000-00 0x0000000 P0 0 # 0000-0 37 38 EMPTY
21 000-000-00 0x0000000 P0 0 # 0000-0 39 40 EMPTY
22 000-000-00 0x0000000 P0 0 # 0000-0 41 42 EMPTY
23 000-000-00 0x01a2446 P0 0 # 0000-0 43 44 EMPTY
1 949-669-00 0x026a850 B 0 # 0809-0 3 0 HAS (Left HAS LA669-00)
13 949-668-00 0x200762d A 0 # 9530-0 0 0 CATALYST HAC
12 949-667-00 0x026a4ee D 0 # 0102-0 0 0 DIF
24 949-669-01 0x2006037 B 0 # 9717-0 4 0 HAS (Right HAS LA669-01)
END
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)