using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^fa0\/(1[0-2]|[1-9])$";
string input = @"fa0/12";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}