$re = '/^fa0\/(1[0-2]|[1-9])$/';
$str = 'fa0/12';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);