package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\bBoost(?:\s*Mobile)?\b`)
var str = `Boost Boost Mobile`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}