$re = '/\bBoost(?:\s*Mobile)?\b/i';
$str = 'Boost Boost Mobile';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);