#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:(?=0[^0]|1[^1]|2[^2]|3[^3]|4[^4]|5[^5]|6[^6]|7[^7]|8[^8]|9[^9])\d)+\d)\1"
Local $sString = "11111212" & @CRLF & _
"124425" & @CRLF & _
"234454" & @CRLF & _
"12314455" & @CRLF & _
"1234567890" & @CRLF & _
"123123" & @CRLF & _
"12345678" & @CRLF & _
"12344567" & @CRLF & _
"12331233" & @CRLF & _
"123123" & @CRLF & _
"321" & @CRLF & _
"321" & @CRLF & _
"321321" & @CRLF & _
"345345345345" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")