$re = '/((?:(?=0[^0]|1[^1]|2[^2]|3[^3]|4[^4]|5[^5]|6[^6]|7[^7]|8[^8]|9[^9])\d)+\d)\1/';
$str = '11111212
124425
234454
12314455
1234567890
123123
12345678
12344567
12331233
123123
321
321
321321
345345345345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);