import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<street>[\\S \\t]+?) ?(?<number>\\d[\\d\\w-\\/ ]*?$)";
final String string = "Wittenberger Straße 9221\n"
+ "Wittenberger Str. 92\n"
+ "Straße des 17. Juni 122a\n"
+ "Straße des 17 Juni 122a\n"
+ "Str. 545 3\n"
+ "Dr.-Külz-Ring 13\n"
+ "Kanalstraße 13 /1\n"
+ "Prager Str. 3 a\n"
+ "Prager Str. 3a\n"
+ "Prager Str. 3 asd\n"
+ "Erika-Mann-Straße 61 - 61s\n"
+ "Erik-Mann-Straße 61 - 62 \n"
+ "Erika-Mann-Straße 61 -62\n"
+ "Erika-Mann-Straße 61b-61c-23d\n"
+ "Erika-Mann-Straße 61b/61c/23d/61b/61c/23d\n"
+ "dsaASa\n\n"
+ "III. Tongraben5\n"
+ "3. Tongrabe 5\n"
+ "55er Str. 5\n"
+ "%§$§§ 2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}