use strict;
my $str = 'Wittenberger Straße 9221
Wittenberger Str. 92
Straße des 17. Juni 122a
Straße des 17 Juni 122a
Str. 545 3
Dr.-Külz-Ring 13
Kanalstraße 13 /1
Prager Str. 3 a
Prager Str. 3a
Prager Str. 3 asd
Erika-Mann-Straße 61 - 61s
Erik-Mann-Straße 61 - 62
Erika-Mann-Straße 61 -62
Erika-Mann-Straße 61b-61c-23d
Erika-Mann-Straße 61b/61c/23d/61b/61c/23d
dsaASa
III. Tongraben5
3. Tongrabe 5
55er Str. 5
%§$§§ 2
';
my $regex = qr/(?<street>[\S \t]+?) ?(?<number>\d[\d\w-\/ ]*?$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}