$re = '/[^\\\\]+(?=\\\\[^\\\\]+$)/m';
$str = 'C:\\Users\\JoseCarlos\\Desktop\\tmp3326\\tmp3326\\1.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);