re = /[^\\]+(?=\\[^\\]+$)/m
str = 'C:\\Users\\JoseCarlos\\Desktop\\tmp3326\\tmp3326\\1.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end