package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[tr\d+,\d+,\d+,\d+\]`)
var str = `[tr1,1,70,18][jl2]39th St [nl1]Adams Blvd [tr71,1,39,18][jl3]$0.70[nl1]$0.80[tr1,19,110,8][jl3]HOV2+ W/FLEX $0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}