const regex = /\[tr\d+,\d+,\d+,\d+\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[tr\\d+,\\d+,\\d+,\\d+\\]', 'g')
const str = `[tr1,1,70,18][jl2]39th St [nl1]Adams Blvd [tr71,1,39,18][jl3]\$0.70[nl1]\$0.80[tr1,19,110,8][jl3]HOV2+ W/FLEX \$0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}