#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)<code>[^<]*</code>"
Local $sString = "<p>I am trying to have the \"Birthday\" and \"Name\" properties of an Org-mode entry added to the agenda automatically:</p>\n\n<pre><code>* John\n :PROPERTIES:\n :Name: John\n :Birthday: (5 4 1900)\n :END:\n</code></pre>\n\n<p>I found a way to add an entry at the correct anniversary date in the agenda by inserting the following line right after the properties:</p>\n\n<pre><code>%%(apply 'diary-anniversary (read (org-entry-get nil \"Birthday\"))) John\n</code></pre>\n\n<p>However, using this code, I still have to enter the name manually. Is there a way to have the value of the \"Name\" property added to the diary text automatically for all entries?</p>\n\n<p><strong>EDIT 1</strong>: the example did not work before, now added parantheses around the value of the birthday property</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")