use strict;
my $str = '<p>I am trying to have the \\"Birthday\\" and \\"Name\\" properties of an Org-mode entry added to the agenda automatically:</p>\\n\\n<pre><code>* John\\n :PROPERTIES:\\n :Name: John\\n :Birthday: (5 4 1900)\\n :END:\\n</code></pre>\\n\\n<p>I found a way to add an entry at the correct anniversary date in the agenda by inserting the following line right after the properties:</p>\\n\\n<pre><code>%%(apply \'diary-anniversary (read (org-entry-get nil \\"Birthday\\"))) John\\n</code></pre>\\n\\n<p>However, using this code, I still have to enter the name manually. Is there a way to have the value of the \\"Name\\" property added to the diary text automatically for all entries?</p>\\n\\n<p><strong>EDIT 1</strong>: the example did not work before, now added parantheses around the value of the birthday property</p>';
my $regex = qr/<code>[^<]*</code>/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}