package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\(]*)\(([^, ]*)\)(?:, )?(?:\n)?`)
var str = `operator1(value), operator2(value), operator_n(value),
operator1(value), operator2(value)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}