$re = '/([^\(]*)\(([^, ]*)\)(?:, )?(?:\n)?/';
$str = 'operator1(value), operator2(value), operator_n(value),
operator1(value), operator2(value)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);