$re = '~https?://(?|media\.giphy\.com/media/([^ /\n]+)/giphy\.gif|i\.giphy\.com/([^ /\n]+)\.gif|giphy\.com/gifs/(?:.*-)?([^ /\n]+))~i';
$str = 'http://i.giphy.com/VmzI60RQG0fuw.gif
https://media.giphy.com/media/VmzI60RQG0fuw/giphy.gif
http://giphy.com/gifs/music-videos-mariah-carey-dreamlover-VmzI60RQG0fuw
http://giphy.com/gifs/VmzI60RQG0fuw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);